Reviews of bikes and cycling equipment by cyclists, for cyclists

Customer reviews for Token Alloy Tufo Valve Extender

Token Alloy Tufo Valve Extender

Overall rating:
3.667 / 5
3.7
 / 
5
(3 reviews) 3
Open Ratings Snapshot
Rating breakdown 3 reviews
5 Stars
2
4 Stars
0
3 Stars
0
2 Stars
0
1 Star
1
2 out of 3(67%)reviewers recommend this product.
Customer questions and answers:
5 Questions | 5 Answers
Customer reviews for Token Alloy Tufo Valve Extender
Review 1 for Token Alloy Tufo Valve Extender
Overall rating 
5 / 5
5 / 5
IanL
Country:South Africa
Age:55-65
Style:Road Cyclist
Experience:Expert
Gender:Male
It was bought:Manchester - National Cycling Centre

Valve Extender

Posted25 October 2013
Yes, I recommend this product.
Pros: Good value, Good quality
Great for Carbon Deep Section and Full DIsk wheels. Quick and easy to fit.
0points
0of 0voted this as helpful.
Thank you! You have successfully submitted a comment for this review.
Review 2 for Token Alloy Tufo Valve Extender
Overall rating 
5 / 5
5 / 5
Derek001

Great

Posted06 June 2013
Yes, I recommend this product.
These worked fine for me. Unlike some extenders which give their total length, so the amount they extend the valve by is about 10mm less, these seem to extend the valve by the same length as they are sized as - so these were a little longer than I expected but product is good. Fits a standard Presta valve.
+1point
1of 1voted this as helpful.
Thank you! You have successfully submitted a comment for this review.
Review 3 for Token Alloy Tufo Valve Extender
Overall rating 
1 / 5
1 / 5
ahmad
from Brunei
Age:25-34
Style:Road Cyclist
Experience:Regular
Gender:Male
It was bought:Online

Wont Fit!!!

Posted28 October 2011
No, I do not recommend this product.
Cons: wont fit
I cant seem to screw it on the head of the tube.
I have tried on both Kenda and Conti tubes. Still will not screw on.
-1point
0of 1voted this as helpful.
Thank you! You have successfully submitted a comment for this review.
Read comment (1)
Comments (1)
Customer avatar
Anonymous
Posted 15 June 2013
Sounds like you didn't remove the valve core first.
0points
0of 0voted this comment as helpful.
Comments (1)
Read comment (1)